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 Important Information

Warranty
The GPIB hardware is warranted against defects in materials and workmanship for a period of two years from the date of 
shipment, as evidenced by receipts or other documentation. National Instruments will, at its option, repair or replace 
equipment that proves to be defective during the warranty period. This warranty includes parts and labor. 

The media on which you receive National Instruments software are warranted not to fail to execute programming 
instructions, due to defects in materials and workmanship, for a period of 90 days from date of shipment, as evidenced 
by receipts or other documentation. National Instruments will, at its option, repair or replace software media that do not 
execute programming instructions if National Instruments receives notice of such defects during the warranty period. 
National Instruments does not warrant that the operation of the software shall be uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside 
of the package before any equipment will be accepted for warranty work. National Instruments will pay the shipping costs 
of returning to the owner parts which are covered by warranty.

National Instruments believes that the information in this manual is accurate. The document has been carefully reviewed 
for technical accuracy. In the event that technical or typographical errors exist, National Instruments reserves the right to 
make changes to subsequent editions of this document without prior notice to holders of this edition. The reader should 
consult National Instruments if errors are suspected. In no event shall National Instruments be liable for any damages 
arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL  INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS 
ANY WARRANTY OF MERCHANTABILITY  OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’ S RIGHT TO RECOVER DAMAGES CAUSED 
BY FAULT OR NEGLIGENCE ON THE PART OF NATIONAL  INSTRUMENTS SHALL BE LIMITED  TO THE AMOUNT THERETOFORE PAID BY THE 
CUSTOMER. NATIONAL  INSTRUMENTS WILL  NOT BE LIABLE  FOR DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, 
OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF. This limitation of the liability of 
National Instruments will apply regardless of the form of action, whether in contract or tort, including negligence. 
Any action against National Instruments must be brought within one year after the cause of action accrues. National 
Instruments shall not be liable for any delay in performance due to causes beyond its reasonable control. The warranty 
provided herein does not cover damages, defects, malfunctions, or service failures caused by owner’s failure to follow 
the National Instruments installation, operation, or maintenance instructions; owner’s modification of the product; 
owner’s abuse, misuse, or negligent acts; and power failure or surges, fire, flood, accident, actions of third parties, or 
other events outside reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, 
including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without 
the prior written consent of National Instruments Corporation.

Trademarks
CVI™ and NI-488.2™ are trademarks of National Instruments Corporation.

Product and company names listed are trademarks or trade names of their respective companies.

WARNING REGARDING MEDICAL AND CLINICAL USE OF NATIONAL INSTRUMENTS PRODUCTS
National Instruments products are not designed with components and testing intended to ensure a level of reliability 
suitable for use in treatment and diagnosis of humans. Applications of National Instruments products involving medical 
or clinical treatment can create a potential for accidental injury caused by product failure, or by errors on the part of the 
user or application designer. Any use or application of National Instruments products for or involving medical or clinical 
treatment must be performed by properly trained and qualified medical personnel, and all traditional medical safeguards, 
equipment, and procedures that are appropriate in the particular situation to prevent serious injury or death should always 
continue to be used when National Instruments products are being used. National Instruments products are NOT intended 
to be a substitute for any form of established process, procedure, or equipment used to monitor or safeguard human health 
and safety in medical or clinical treatment.
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About This Manual

This manual contains instructions to help you use the GPIB analyzer 
software. The GPIB analyzer software is meant to be used with 
Windows 95 or Windows NT and with one of the National Instruments 
GPIB interfaces that supports the GPIB analyzer. This manual assumes that 
you are already familiar with the Windows system you are using.

Organization of This Manual
The GPIB Analyzer User Manual is organized as follows:

• Chapter 1, GPIB Analyzer Overview, gives an overview of the GPIB 
analyzer software.

• Chapter 2, GPIB Analyzer Features, describes the features of the 
GPIB analyzer application.

• Chapter 3, How To..., describes how to accomplish specific tasks 
within the GPIB analyzer application.

• Chapter 4, Tutorial, contains a hands-on tutorial to help you practice 
using the different features of the GPIB analyzer application.

• Chapter 5, Examples, contains several examples that illustrate how to 
use the GPIB analyzer application to solve your IEEE 488 problems.

• Appendix A, Common Questions, answers common questions about 
the GPIB analyzer application.

• Appendix B, Capture Display Mnemonics, explains the mnemonics 
that appear in the capture display of the GPIB analyzer application.

• Appendix C, Customer Communication, contains forms you can use to 
request help from National Instruments or to comment on our products 
and manuals.

• The Glossary contains an alphabetical list and description of terms 
used in this manual, including abbreviations, acronyms, metric 
prefixes, mnemonics, and symbols. 

• The Index contains an alphabetical list of key tems and topics in this 
manual, including the pagewhere you can find each one.
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Conventions Used in This Manual
The following conventions are used in this manual:

<> Angle brackets enclose the name of a key on the keyboard—for example, 
<shift>. Angle brackets containing numbers separated by an ellipsis 
represent a range of values associated with a bit or signal name—for 
example, DBIO<3..0>.

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options» Substitute 
Fonts directs you to pull down the File menu, select the Page Setup item, 
select Options, and finally select the Substitute Fonts options from the 
last dialog box.

bold Bold text denotes the names of menus, menu items, parameters, dialog 
boxes, dialog box buttons or options, icons, windows, Windows 95 tabs, 
or LEDs.

bold italic Bold italic text denotes an activity objective, note, caution, or warning.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction 
to a key concept. This font also denotes text from which you supply the 
appropriate word or value, as in Windows 3.x.

monospace Text in this font denotes text or characters that you should literally enter 
from the keyboard, sections of code, programming examples, and syntax 
examples. This font is also used for the proper names of disk drives, paths, 
directories, programs, subprograms, subroutines, device names, functions, 
operations, variables, filenames and extensions, and for statements and 
comments taken from programs.

Related Documents
The following documents contain information that you may find helpful as 
you read this manual:

• ANSI/IEEE Standard 488.1-1987, IEEE Standard Digital Interface for 
Programmable Instrumentation

• ANSI/IEEE Standard 488.2-1992, IEEE Standard Codes, Formats, 
Protocols, and Common Commands

• Microsoft Windows 95 User’s Guide, Microsoft Corporation

• Microsoft Windows NT User’s Guide, Microsoft Corporation
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Customer Communication
National Instruments wants to receive your comments on our products 
and manuals. We are interested in the applications you develop with our 
products, and we want to help if you have problems with them. To make it 
easy for you to contact us, this manual contains comment and configuration 
forms for you to complete. These forms are in Appendix C, Customer 
Communication, at the end of this manual.
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1
GPIB Analyzer Overview

This chapter gives an overview of the GPIB analyzer software.

The GPIB analyzer is an application that you can use for testing, 
debugging, and analysis. It can monitor, capture, and participate in bus 
activity on the GPIB. You can use the GPIB analyzer to test and debug your 
own applications by monitoring and capturing GPIB activity while your 
application is running. The analyzer also has tools to help you analyze the 
data that you capture. Analyzing this data can help you solve many of the 
difficulties associated with GPIB communication, such as addressing 
inconsistencies, protocol violations, and simple bus timeout conditions.

The GPIB analyzer software works under Windows 95 only when an 
AT-GPIB/TNT+ or PCMCIA-GPIB+ is installed. It works under 
Windows NT only when an AT-GPIB/TNT+ or PCI-GPIB+ is installed.

Online Help
The GPIB analyzer application includes an online help system, which you 
can access while running the analyzer by pressing <F1> or using the Help 
menu. The online help contains basically the same information as this user 
manual.

Features of the GPIB Analyzer
The GPIB analyzer, created with the National Instruments 
LabWindows/CVI development environment, has several major features.

• Settings configuration—Allows configuration of capture and trigger 
settings.

• Action window—Starts and stops capturing and/or triggering.

• Bus Monitor window—Displays and allows you to modify the state of 
each of the GPIB data and control lines.

• Capture Display window—Displays captured GPIB events.

• Search capability—Allows searches within a capture display.
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Capturing Data with the GPIB Analyzer
The analyzer can capture and display data, including any combination of 
the following GPIB events: data transfers, command transfers, control line 
transitions, handshake line transitions, and parallel poll responses. You can 
participate in handshaking or do a non-intrusive capture.

You might want to capture and display data based on a specific bus event 
without knowing when the event might occur. In this case, you can specify 
a trigger condition and capture any number of events before and after the 
trigger condition occurs. The capture operation proceeds according to the 
settings configuration. 

The analyzer can perform the acceptor handshake while capturing, and it 
can time stamp captured events. The number of recorded capture events can 
be configured and is limited only by the memory available on your 
computer.

Analyzing Captured Data with the GPIB Analyzer
The GPIB analyzer provides several features to help you analyze data that 
you have captured:

• Use markers for highlighting and examining specific transactions in 
the captured data, and for determining elapsed time between captured 
events.

• Use the flexible pattern-search utility to locate specific bus patterns.

• Store captured data to disk for later review in the capture display.

• Print captured data to a selected printer.

You can reload previously saved capture events for later review and 
analysis. You can even have multiple capture displays open, so that you can 
analyze current bus activity in one display and the previously captured data 
in another display. 

Installing the GPIB Analyzer
For detailed instructions on how to install the GPIB analyzer software, refer 
to the getting started manual that came with your GPIB hardware.

Starting the GPIB Analyzer
Launch the GPIB analyzer application by selecting the GPIB Analyzer 
item under Start»Programs»GPIB Analyzer Software.
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Exiting the GPIB Analyzer
Choose File»Exit to close the GPIB analyzer application. The analyzer 
prompts you to save any capture display that contains unsaved GPIB 
events. The current settings for capturing and triggering are saved 
automatically, and they are automatically loaded the next time you start the 
GPIB analyzer application.
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2
GPIB Analyzer Features

This chapter describes the features of the GPIB analyzer application. 

The features are as follows:

• Settings configuration—Allows configuration of capture and trigger 
settings.

• Action window—Starts and stops capturing and/or triggering.

• Bus Monitor window—Displays and allows you to modify the state of 
each of the GPIB data and control lines.

• Capture Display window—Displays captured GPIB events.

• Search capability—Allows searches within a capture display.

The main GPIB analyzer window is shown in Figure 2-1. The Action and 
Bus Monitor windows are always open. 
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Figure 2-1.  Main Window of the GPIB Analyzer

Main GPIB Analyzer Window
The GPIB Analyzer opens with the main window, which includes the 
Action and Bus Monitor windows. The following sections describe the 
menu choices from the main window of the GPIB analyzer.

File»New Capture Display
Choosing New Capture Display from the File menu opens a new, active 
capture display. When you start capturing GPIB events by selecting one of 
the capture buttons in the Action window, you can view them in the active 
capture display.

File»Open Capture File...
Choosing Open Capture Display... from the File menu in the main 
window opens a previously saved window of captured GPIB events as an 
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inactive display. Filenames for GPIB analyzer capture files typically use 
the .CAP extension.

File»Exit
Choosing Exit  from the File menu in the main window closes the GPIB 
analyzer application. The analyzer prompts you to save any capture display 
that contains unsaved GPIB events. The current settings for capturing and 
triggering are saved automatically, and they are automatically loaded the 
next time you start the GPIB analyzer.

Settings»Change Settings...
Choosing Change Settings... from the Settings menu in the main window 
opens the Settings configuration dialog box so that you can change the 
settings used for capturing GPIB events and triggering on specific GPIB 
events. See the Settings Configuration section, later in this chapter, for 
more information.

Settings»Load Settings...
Choosing Load Settings... from the Settings menu in the main window 
opens a file of previously saved settings to be used for capturing GPIB 
events and triggering on specific GPIB events. Filenames for GPIB 
analyzer settings typically use the .SET  extension.

Settings»Save Settings As...
Choosing Save Settings As... from the Settings menu in the main window 
allows you to save the current settings used for capturing GPIB events and 
triggering. Whenever possible, use the .SET  extension for GPIB analyzer 
settings filenames.

Windows Menu
The Windows menu in the main window lists all of the currently open 
GPIB analyzer windows. When you select a window from this menu, it is 
brought to the front.

Help Menu
The Help menu in the main window accesses the online help for the GPIB 
analyzer. It also accesses information about the analyzer software, such as 
version number and hardware configuration.
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Settings Configuration
Capture and trigger settings can be configured by selecting Change 
Settings... from the Settings menu in the main window. Figure 2-2 shows 
the Settings configuration dialog box

.

Figure 2-2.  Settings Configuration Dialog Box 

The configured settings apply only to active capture displays. Note that the 
settings in this window cannot be changed unless capturing and triggering 
are turned off (use the Action window to turn off capturing and triggering).

The Retain up to _____ capture events edit control specifies the number 
of captured GPIB events that can be kept in the internal capture memory 
buffer. When the buffer becomes full, the oldest GPIB events are discarded 
to make space for new GPIB events.

The Participate in Acceptor Handshake checkbox selects whether or not 
the GPIB analyzer participates in acceptor handshake on the GPIB. If it is 
checked, the analyzer hardware participates in the GPIB handshake at the 
handshake rate selected from the Handshake rate list box. You can use this 
feature to slow down GPIB transfers to a particular rate or to avoid 
overflow errors.
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The Handshake rate list box selects the rate at which the GPIB analyzer 
accepts data and command bytes. It is disabled unless Participate in 
Acceptor Handshake is checked. The Maximum  option allows the 
analyzer to accept bytes at the fastest rate possible without causing 
overflow errors. The other options slow down all GPIB transfers to a rate 
no greater than that specified.

The Enable Timestamping checkbox enables or disables timestamping of 
captured GPIB events by the GPIB analyzer. Timestamp resolution is at 
50 ns intervals. When checked, timestamping is enabled and the GPIB 
analyzer records the time that has elapsed between each GPIB event 
captured.

Capture Stimulus Configuration
The Capture Stimulus group box in the Settings dialog box lets you 
choose the various types of GPIB events to capture.

The Data Transfers checkbox enables the capture of GPIB data bytes. 
Both IEEE 488 and HS488 data bytes are captured.

The Command Transfers checkbox enables the capture of GPIB 
command bytes. 

The Control Line Transitions  checkbox enables the capture of EOI, ATN, 
SRQ, REN, and IFC GPIB control line transitions. These lines are used to 
manage the GPIB interface system.

The Handshake Line Transitions checkbox enables the capture of GPIB 
handshake line transitions (NRFD, NDAC, DAV). The handshake lines are 
used to control the transfer of both GPIB data and command bytes. 
Selecting this option causes a large amount of GPIB events to be captured 
and may cause overflow errors; therefore, you should select it only when 
you need to debug a problem with the handshaking of a particular GPIB 
device. Note that some handshake line transitions may fall within the 50 ns 
resolution of the analyzer, so they might be captured and displayed as a 
single event when you check this box.

The Parallel Poll Responses checkbox enables the GPIB analyzer to 
capture all GPIB parallel poll responses. To delimit the beginning of a 
GPIB parallel poll, the analyzer captures the assertion of ATN and EOI. 
The next capture, after 2 µs, denotes the beginning of the parallel poll 
response. The analyzer then captures data each time the response on a GPIB 
data line changes. To delimit the end of a GPIB parallel poll, the analyzer 
captures the point at which EOI is unasserted. 
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For more information about setting the capture stimulus, refer to Configure 
the Settings in Chapter 3, How To....

Trigger Condition Configuration
The Trigger Condition  group box in the Settings dialog box lets you 
configure the GPIB data and control lines that define the trigger condition.

You can enter the GPIB data lines trigger condition as an ASCII value in 
the ASCII  edit control, a hexadecimal value in the Hex edit control, or a 
binary value in the D8 to D1 spin controls. Note that the GPIB data trigger 
condition is replicated in all three representations: ASCII, hexadecimal, 
and binary. Note also that the D8 to D1 spin controls have the added feature 
of letting you select x or “don’t care” values for particular GPIB data lines 
whose states are not relevant to the GPIB data trigger condition. For 
example, if you want to configure the GPIB data trigger so that any 
non-ASCII GPIB data causes a trigger, D8 should be set to 1 and D7, D6, 
D5, D4, D3, D2, and D1 should be set to x.

You can enter the GPIB control lines trigger condition for each of the GPIB 
control lines using the spin controls for EOI , ATN , SRQ, REN, IFC , 
NRFD, NDAC, and DAV. Note that the x value (“don’t care”) can be 
chosen for GPIB control lines whose state is not relevant to the trigger 
condition.

Configuration of Other Trigger Settings
Immediately below the Trigger Condition  group box in the Settings 
dialog box are the controls that allow you to configure the other trigger 
settings. Three of these controls are spin controls. 

The spin control on the left configures how data is to be captured around 
the first trigger point. The choices are Capture around first trigger point  
and Capture indefinitely after trigger point . If you select Capture 
around first trigger point , capture is stopped at a specified point after the 
first trigger is noticed, and the three controls below that spin control are 
enabled. These controls are the Thumb denotes first trigger point slider 
control, the events before trigger edit control, and the events after trigger 
edit control. These three additional controls specify the exact location in the 
capture buffer for the first trigger point. If you select Capture indefinitely 
after trigger point , these three controls are disabled and capture continues, 
even after the trigger condition is noticed.

The two spin controls on the right side below the Trigger Condition  group 
box configure the number of triggers that get recorded and whether or not 
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beep sounds should be made when the trigger condition is noticed. If you 
select Trigger on first occurrence of condition, a single trigger is 
recorded in the capture buffer. If you select Trigger on all occurrences of 
condition, every instance of the trigger condition is recorded in the capture 
buffer. To configure beeping that you want to accompany trigger 
conditions, select Do not sound a beep on any trigger, Sound a beep on 
first trigger point , or Sound a beep on all trigger points.

For more information about selecting the trigger settings, refer to the 
Configure Trigger Settings section of Chapter 3, How To....

Exiting the Settings Dialog Box
Clicking the OK  button in the Settings dialog box saves the changes made 
to the settings and closes the window. These settings are used the next time 
you start capturing and/or triggering. If you want to save these settings to a 
file for later use, choose Save Settings As... in the Settings menu of the 
main window.

Clicking the Cancel button cancels the changes made to the settings and 
closes the window.

Clicking the Default button restores the settings to match the default 
values, without closing the window.

Action Window
The Action window contains controls you can use to turn capturing and/or 
triggering on and off. The Action window, shown in Figure 2-3, is always 
open. If the window is hidden, use Windows»Action Window to bring it 
to the front.

Figure 2-3.  Action Window

When the GPIB analyzer application is started, capture and trigger are 
both off.

Clicking the Capture button causes the analyzer to begin capturing GPIB 
events into the active capture display. Data is captured according to the 
current capture configuration settings. Triggering is not enabled.
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Clicking the Capture & Trigger  button causes the analyzer to begin 
capturing GPIB events into the active capture display and to monitor for 
trigger conditions. Data is captured according to the current capture 
configuration settings, and triggers are monitored according to the current 
trigger configuration. The capture and trigger configuration can be 
modified using the settings configuration described in the Settings 
Configuration section, earlier in this chapter.

Clicking the Off  button causes the analyzer to stop capturing GPIB events 
and stop monitoring for trigger conditions.

Note the following capabilities concerning captures:

• You can switch back and forth between Capture and Capture & 
Trigger  during the capture without losing data. 

• The GPIB analyzer timer resolution is 50 ns, so the fastest rate of 
capturing GPIB events possible is one GPIB event every 50 ns.

• Multiple capture displays can be viewed simultaneously.

Bus Monitor Window
The Bus Monitor window allows you to monitor and control each of the 16 
GPIB data and control lines. It also allows you to accept GPIB data, one 
byte at a time. The Bus Monitor window, shown in Figure 2-4, is always 
open. If the Bus Monitor window is hidden, use Windows»Bus Monitor 
to bring it to the front.

Figure 2-4.  Bus Monitor Window 

The state of the GPIB data and control lines is displayed on the row of 
LEDs and the upper ASCII  and Hex edit controls. You can alter the value 
of the GPIB data and control lines using the row of binary switches and the 
lower ASCII  and Hex edit controls.
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You can enter the GPIB data value as an ASCII value in the ASCII  edit 
control, a hexadecimal value in the Hex edit control, or a binary value in 
the 8 to 1 binary switches. Note that the GPIB data value is replicated in all 
three representations: ASCII, hexadecimal, and binary.

You can enter the GPIB control value using the EOI , ATN , SRQ, REN, 
IFC , NRFD, NDAC, and DAV  binary switches. The up position 
corresponds to the assertion of the line.

Clicking the Unassert Lines button moves all of the binary switches to the 
down (unasserted) position and disables the Accept Byte button.

Clicking the Enable Accept Byte button prepares the analyzer to accept 
either GPIB data or command bytes, one byte at a time, and changes the 
button title to Disable Accept Byte. The analyzer unasserts NRFD and 
asserts NDAC. When another GPIB device on the bus asserts the DAV 
signal, indicating that data is available, clicking the Accept Byte button 
accepts the byte and prepares for the next byte. Enabling this feature 
disables the manual binary switches for the NRFD and NDAC control lines. 
When finished accepting data, clicking the Disable Accept Byte button 
releases control of the handshaking lines.

The Accept Byte button causes the analyzer to examine the state of the 
DAV line to determine whether another GPIB device is trying to send a 
byte. If DAV is unasserted, clicking on Accept Byte has no effect because 
no data is available to be accepted. If DAV is asserted, clicking on Accept 
Byte accepts a single byte of GPIB data by automatically toggling NRFD 
and NDAC in the proper sequence. Before you can use this button, you 
must click on the Enable Accept Byte button in the Bus Monitor window.

Capture Display Window
The Capture Display window displays captured GPIB events. You can 
have more than one capture display open at one time, and capture displays 
can be either active or inactive. Active capture displays show GPIB events 
as they are being captured. Inactive capture displays show previously 
captured events, so that they are unaffected by newly captured GPIB 
events.

To open an active Capture Display window, choose New Capture Display 
from the File menu in the main window. To open an inactive Capture 
Display window, choose Open Capture File... from the File menu in the 
main window. You can also use the Switch to Inactive (Active) Display 
button in an active (or inactive, respectively) Capture Display window to 
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switch back and forth between the two types of Capture Display windows. 
Figure 2-5 shows an example of an inactive Capture Display window.

Figure 2-5.  Capture Display Window (Inactive)

Menu Choices from a Capture Display
Choosing Save As... from the File menu saves the GPIB events in the 
capture display to a file. Both inactive and active (provided capture is 
turned off) capture displays can be saved. Whenever possible, use the .CAP 
extension for GPIB analyzer capture files.

Choosing Print... from the File menu prints the contents of an inactive 
capture display to a selected printer.

Choosing Export... from the File menu saves the GPIB events in an 
inactive capture display to an ASCII text file, which can be imported into 
other applications such as word processors. You cannot import the ASCII 
file back into the GPIB analyzer.

Choosing Close... from the File menu closes the Capture Display window. 
The analyzer program prompts you to save any unsaved GPIB events.

The Help menu accesses the online help for the GPIB analyzer.
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Capture Settings in a Capture Display 
The Capture Settings group box contains information on the capture 
settings configuration that was defined when the capture was made. It 
contains the following items:

• The Stimulus field lists the capture stimuli (as defined by the settings 
configuration) used during capture of the GPIB events in the capture 
display.

• The Capture size field lists the capture buffer size (as defined by the 
settings configuration) used during capture of the GPIB events in the 
capture display.

• The Handshake rate field lists the value of the handshake rate (as 
defined by the settings configuration) used during capture of the GPIB 
events in the capture display.

Markers & Statistics in an Inactive Capture Display
The Markers & Statistics group box provides capture statistics based on 
various markers in the capture buffer. In addition to Begin, End, and 
Cursor markers, you can add markers (M0, M1, M2, and so on) to the 
capture buffer by double-clicking on the entry to be marked. The capture 
statistics displayed include the Number of capture events between 
markers, the Time elapsed between markers, and the Capture events per 
second for the data between the markers. Note that markers and statistics 
are available only in inactive Capture Display windows.

The From box is used to select the beginning marker used to calculate the 
capture statistics.

The To box is used to select the ending marker used to calculate the capture 
statistics.

The Go To box allows you to go to a particular marker in the capture 
display.

Controls in a Capture Display
The controls in a Capture Display window include Find..., Find Next, and 
Switch to Inactive/Active Display buttons and a Display Mode spin 
control.

Click the Find... button to open the Find dialog box, which you can use to 
specify search criteria for finding a particular GPIB event in an inactive 
Capture Display window. 
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Click the Find Next button to search for the next occurrence of your search 
criteria in the inactive capture display. This button is disabled if you have 
not yet entered your search criteria in the Find dialog box.

Click the Switch to Active/Inactive Display button to switch between 
active and inactive capture display modes. Active capture displays show 
GPIB events as they are being captured. Inactive displays show previously 
captured GPIB events. With inactive displays, you can place markers, view 
statistics about the captured GPIB events, and search for specific GPIB 
events. Switching from inactive to active display deletes all captured GPIB 
events and markers, but the analyzer prompts you to save your data before 
switching to an active display.

The Display mode spin control chooses the display mode used for the 
captured GPIB events. In Detailed display mode, captured GPIB events are 
shown one per line. In Summarized display mode, multiple events can be 
shown on each line. Line transitions are displayed on separate lines, but 
data and command transfers are grouped on the same line. In both display 
modes, data transfers are shown in blue, command transfers are shown in 
green, and control line transitions, handshake line transitions, and parallel 
poll responses are all shown in black. 

Capture Data in a Capture Display Window
The capture display shows captured GPIB events, markers, timestamps, 
and helpful mnemonics. It can also show control line and handshake line 
transitions. If the line name is followed by an up arrow, the line went from 
unasserted to asserted. If the line name is followed by a down arrow, the 
line went from asserted to unasserted. This field might also display an 
overflow error message if the FIFO is full and events are lost.

For specific information about how to interpret the capture display, refer to 
the Analyze Captured Data section of Chapter 3, How To..., or to 
Appendix B, Capture Display Mnemonics. 
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Search Capability
The Find... and Find Next buttons in the capture display allow you to 
search for specific GPIB data and control line patterns, data strings, or 
trigger points in an inactive capture display.

To do a new search, click on the Find... button in an inactive capture display 
to bring up a Find dialog box similar to the one shown in Figure 2-6. To 
repeat the search, click on the Find Next button in the inactive capture 
display.

Figure 2-6.  Find Dialog Box

To find a trigger point in the Capture Display window, check the Find 
Trigger  checkbox and then click the Find button. 

To find a particular data and control line pattern, set the pattern of the data 
lines using either the ASCII  or Hex edit controls or the D8 to D1 spin 
controls (for binary values), and set the pattern of the control lines using the 
EOI , ATN , SRQ, REN, IFC , NRFD, NDAC, and DAV  spin controls. 
Notice that the spin controls allow you to select 0 (unasserted), 1 (asserted), 
or x (don’t care) for each data and control line. When the data and control 
lines have been selected, click the Find button.
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To find a series of GPIB data and control line patterns, use the Insert 
Above, Insert Below, and Delete buttons to add and remove entries from 
the Find String  list box until it contains the desired series of GPIB data and 
control line patterns. Click the Find button to conduct the search.

Use the Search Direction switch to specify the direction to search from the 
current cursor position in the capture display.

Click the Cancel button to cancel the search and close the Find dialog box.
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3
How To...

This chapter describes how to accomplish specific tasks within the GPIB 
analyzer application. 

Start the GPIB Analyzer
Launch the GPIB analyzer application by selecting the GPIB Analyzer 
item under Start»Programs»GPIB Analyzer Software.

Exit the GPIB Analyzer
Choose File»Exit to close the GPIB analyzer application. The analyzer 
prompts you to save any capture display that contains unsaved GPIB 
events. The current settings for capturing and triggering are saved 
automatically, and they are automatically loaded the next time you start the 
GPIB analyzer.

Start and Stop Capture of Data
To begin capturing data, complete the following steps:

1. Configure the capture settings and trigger conditions using 
Settings»Change Settings....

2. If an active display is not already open, open a new Capture Display 
window using File»New Capture Display.

3. Bring the Action window to the front using Windows»Action 
Window.

4. Click on the Capture or Capture & Trigger  button in the Action 
window to begin capturing data. 

To stop capturing new data, click on the Off  button in the Action window.
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Monitor or Participate in GPIB Activity

View/Change the State of GPIB Data and Control Lines
You can view or change the state of the GPIB data and control lines from 
within the Bus Monitor window. 

The state of the GPIB data and control lines is displayed on the row of 
LEDs and the upper ASCII  and Hex edit controls. You can alter the value 
of the GPIB data and control lines using the row of binary switches and the 
lower ASCII  and Hex edit controls.

You can enter the GPIB data value as an ASCII value in the ASCII  edit 
control, a hexadecimal value in the Hex edit control, or a binary value in 
the 8 to 1 binary switches. Note that the GPIB data value is replicated in all 
three representations: ASCII, hexadecimal, and binary.

You can enter the GPIB control value using the EOI , ATN , SRQ, REN, 
IFC , NRFD, NDAC, and DAV  binary switches. The up position 
corresponds to the assertion of the line.

To accept a byte of data on the bus, use the NRFD and NDAC binary 
switches to simulate the IEEE 488 handshake, or use the Accept Byte 
button, which automatically toggles NRFD and NDAC in the correct 
sequence. The Accept Byte button is enabled by clicking on the Enable 
Accept Byte button.

If you are using the Bus Monitor to assert GPIB lines, do not use the 
NI-488.2 ibfind  or ibdev  functions. These functions will unassert the 
lines on the bus, even though the switches in the Bus Monitor window show 
that the lines are asserted. If you encounter this problem, click on the 
Unassert Lines button and avoid using the ibfind  or ibdev  functions.

Accept a Single Byte
To accept a single byte of data on the GPIB, first click on the Enable 
Accept Byte button in the Bus Monitor window. Then click on the Accept 
Byte button in the Bus Monitor window. This action automatically toggles 
the NRFD and NDAC lines in the correct IEEE 488 handshaking sequence 
to accept a single byte. If you disable the Accept Byte feature, you can 
control the NRFD and NDAC lines manually using the binary switches in 
the Bus Monitor window.
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If you try to accept a byte when no GPIB device is currently trying to source 
a byte (DAV unasserted), then toggling the handshake lines or clicking on 
Accept Byte has no effect.

View Previously Captured Data
To open a Capture Display window to view previously saved GPIB events, 
choose File»Open Capture File.... 

Configure the Settings
Settings are configured with the Settings configuration dialog box, which 
you can open by choosing Settings»Change Settings.... 

Configure Capture Settings

Complete the following steps to configure the capture settings:

1. Click the Off  button in the Action window. (Selecting 
Windows»Action Window brings the Action window to the front.)

2. Open the Settings dialog box by choosing Settings»Change 
Settings....

3. Configure the capture settings. Refer to the Settings Configuration 
section of Chapter 2, GPIB Analyzer Features, for details on all the 
capture settings you can configure. 

4. When you are finished making changes, click on OK  in the Settings 
dialog box. 

You can save your capture settings by choosing Settings»Save Settings 
As... and reload them by choosing Settings»Load Settings....

Configure Trigger Settings
Complete the following steps to configure the trigger settings for your 
capture:

1. Click the Off  button in the Action window. (Selecting 
Windows»Action Window brings the Action window to the front.)

2. Open the Settings dialog box by choosing Settings»Change 
Settings....

3. Configure the trigger settings. Refer to the Trigger Condition 
Configuration and Configuration of Other Trigger Settings sections of 
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Chapter 2, GPIB Analyzer Features, for details on all the trigger 
settings you can configure. 

4. When you are finished making changes, click on OK  in the Settings 
dialog box. 

You can save your trigger settings by choosing Settings»Save Settings 
As... and reload them by choosing Settings»Load Settings....

To use the configured trigger settings, start capture using the Capture & 
Trigger  button in the Action window, instead of the Capture button.

Timestamp Capture Events
Timestamping shows you the elapsed time between GPIB events captured 
by the GPIB analyzer. The timestamp information appears in the timestamp 
column of the capture display. 

To enable timestamping, check the Enable Timestamping checkbox in the 
Settings dialog box.

Do a Non-Intrusive Capture
To prevent the GPIB analyzer from participating in acceptor handshaking, 
uncheck the Participate in Acceptor Handshake checkbox in the 
Settings dialog box. If this checkbox is checked, the analyzer participates 
in all handshaking on the GPIB. You might want to select this checkbox to 
slow down the GPIB transfers or to avoid overflow errors.

Avoid Overflow Errors
An overflow error occurs when the GPIB analyzer FIFO hardware buffer 
fills up with GPIB events faster than the software can receive them. If this 
happens, an error message with asterisks and the word “OVERFLOW” 
appears in the capture display, as shown in Figure 3-1.
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Figure 3-1.  Overflow Error

If an overflow error occurs, one or more GPIB events have been lost. You 
can usually avoid overflow errors by making one of the following changes:

• Check the Participate in Acceptor Handshake checkbox in the 
Settings dialog box, and set the Handshaking rate to Maximum . 
This configuration causes the analyzer to hold off when the FIFO is 
almost full. It prevents high speed GPIB data transfers when the FIFO 
is almost full, which can be a common cause of overflow errors.

• Uncheck the Handshake Line Transitions checkbox in the Settings 
dialog box. If this option is selected, you might capture up to six times 
as many GPIB events as when choosing to capture only data and 
command transfers. The reason for this is that when you enable the 
capture of handshake line transitions, you start getting GPIB events 
such as NDAC↑ and NRFD↓, which reflect the multiple changes that 
occur to the states of the GPIB handshake lines for each byte 
transferred on the GPIB. This high volume of events is likely to cause 
overflow errors.

• Uncheck the Enable Timestamping checkbox in the Settings dialog 
box. If you do not need to see the timestamping information, disabling 
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this option can reduce the amount of data transferred from the FIFO 
and reduce the possibility for overflow errors.

• Uncheck the Control Line Transitions  checkbox in the Settings 
dialog box. Some GPIB devices may toggle the control lines 
incorrectly, and overflow errors could result.

• Close all active capture displays while capturing. The analyzer 
captures GPIB events more efficiently if they do not need to be 
displayed immediately. 

• Increase the Retain up to _____ capture events value in the Settings 
dialog box. This field specifies the maximum number of capture events 
retained in the capture buffer.

Save and Reload Capture/Trigger Settings
The analyzer uses the current capture and trigger settings until you change 
them again and automatically saves them when you exit the analyzer 
program. If you want to save the current settings for later use, use 
Settings»Save Settings As.... Whenever possible, use the .SET  extension 
for analyzer settings filenames.

To load a file of previously saved settings, use Settings»Load Settings....

Analyze Captured Data
After you have captured GPIB events, you are ready to view and interpret 
the captured data, calculate statistics, search for specific capture events, 
print the captured data, or save the captured data.

View the Captured Data
You can view the captured GPIB events in either detailed display mode or 
summarized display mode. With detailed display mode, captured GPIB 
events are shown one per line. In summarized display mode, multiple 
events are combined on single lines. Line transitions are displayed on 
separate lines, but data and command transfers are grouped on the same 
line. In either display mode, lines are color coded based on the type of event 
captured. Table 3-1 shows the color coding scheme.
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Read the Timestamp Column
In detailed mode, where each line represents a single capture event, the 
timestamp value represents the time elapsed between the event on that line 
and the event on the previous line. So if you want to determine the time 
elapsed between the capture of the first event and the fifth event, add up the 
timestamp values on the second, third, fourth, and fifth lines. Alternatively, 
you can switch to an inactive display using the Switch to Inactive Display 
button, and put markers on the first and last event of interest, then use the 
From and To fields in the Markers & Statistics group box to have the 
GPIB analyzer calculate a Time elapsed value for you.

In summarized mode, where more than one event can be present on a line, 
the timestamp value represents the time elapsed between the first event on 
that line and the first event on the previous line.

The timestamp column in the capture display shows the timestamp in a 
minute, second, millisecond, microsecond, and nanosecond notation. If the 
timestamp exceeds 60 minutes, the timestamp is shown in an hour, minute, 
and second notation. The abbreviations used for the various time scales are 
listed in Table 3-2. The smallest recordable timestamp is 50 ns.

Table 3-1.  Color Coding in the Capture Display

Type of Event Color

Data transfers Blue

Command transfers Green

Control line transitions Black

Handshake line transitions Black

Parallel poll responses Black

Trigger event Dotted box

Overflow White
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Read the Mnemonics Column
Various mnemonics appear in the right column of the capture display to 
provide a quick interpretation of the captured GPIB events. The column 
may also show line transitions. If the line name is followed by an up arrow 
(↑), the line transitioned from unasserted to asserted. If the line name is 
followed by a down arrow (↓), the line transitioned from asserted to 
unasserted. Note that if the analyzer is capturing handshake line transitions, 
the assertion of DAV represents a GPIB data byte or command byte. For a 
detailed list of the mnemonics and their meanings, refer to Appendix B, 
Capture Display Mnemonics.

Search for a Capture Event
To search for a specific GPIB event within a capture display from the 
current cursor location, complete the following steps:

1. Switch to an inactive Capture Display window. 

2. Click on the Find... button.

3. Enter your search criteria in the Find dialog box. 

To find a trigger point in the Capture Display window, check the Find 
Trigger  checkbox. 

To find a particular data and control line pattern, set the pattern of the 
data lines using either the ASCII  or Hex edit controls or the D8 to D1 
spin controls (for binary values), and set the pattern of the control lines 
using the EOI , ATN , SRQ, REN, IFC , NRFD, NDAC, and DAV  spin 
controls. Notice that the spin controls allow you to select 0 
(unasserted), 1 (asserted), or x (don’t care) for each data and 
control line.

Table 3-2.  Timestamp Abbreviations in the Capture Display Window

Time Unit Abbreviation

Nanoseconds ns

Microseconds us

Milliseconds ms

Seconds s

Minutes mi

Hours hr
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To find a series of GPIB data and control line patterns, use the Insert 
Above, Insert Below, and Delete buttons to add and remove entries 
from the Find String  list box until it contains the desired series of 
GPIB data and control line patterns.

Use the Search Direction switch to specify the direction to search 
from the current cursor position in the capture display.

4. Click on the Find button in the Find dialog box. This action 
automatically closes the Find dialog box and takes you from the 
current cursor position to the first GPIB event in the capture display 
that matches your search criteria. 

To find the next occurrence, click on the Find Next button.

Mark Capture Events to Show Statistics
Markers are allowed only in inactive capture displays. All inactive capture 
displays contain at least two markers: Begin and End. Single-clicking 
places the cursor in a capture display. Double-clicking places markers in a 
capture display and removes placed markers. Markers are labeled M0, M1, 
M2, and so on, as they are created.

After you have placed your markers, you can use the From and To controls 
in the Markers & Statistics group box to examine statistics about the 
captured data.

If you are using summarized display mode, you might have more than one 
marker for each line. In this case, the letter M  appears in the marker 
column. You can click on the M  several times to see each marker for 
that line.

Print and Save Captured Data
To print the contents of an inactive Capture Display window, use 
File»Print.... You can print the entire capture display or limit the printing 
to captured events between particular markers.

Both inactive and active (if capturing is turned off) capture displays can be 
saved to a file. To save the data in a Capture Display window, use File»Save 
As.... Whenever possible, use the .CAP extension for saving capture display 
files. Captured data is saved in an analyzer-specific format and can be 
reopened as an inactive capture display.
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You can also export an inactive capture display as an ASCII text file to 
another application, such as a word processor. Use File»Export... to export 
the captured data. You can export captured data as text in both detailed and 
summarized formats. You cannot import the ASCII text file back into the 
GPIB analyzer.
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4
Tutorial

This chapter contains a hands-on tutorial to help you practice using the 
different features of the GPIB analyzer application. 

Before you start the tutorial, check the following:

• Make sure that the GPIB software, GPIB analyzer software, and GPIB 
hardware are installed on your computer. For installation instructions, 
refer to your getting started manual.

• Disconnect all GPIB cables from your GPIB hardware.

Part 1: Capture and View New Data

1. Open the GPIB analyzer application by selecting 
Start»Programs»GPIB Analyzer Software»GPIB Analyzer.

When you open the application, a new Capture Display window and 
the Action window are visible.

2. Choose Settings»Change Settings... to bring up the Settings dialog 
box.

3. In the Settings dialog box, click on the Default button to reset to the 
default settings.

4. In the Capture Stimulus section, choose to capture the following 
stimuli: data transfers, command transfers, control line transitions, and 
parallel poll responses. Do not select handshake line transitions.

5. Click in the Retain up to _____ capture events box and change the 
setting to 60,000 capture events.

You do not need to change the trigger settings because this part of the 
tutorial does not use triggering. 
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The Settings dialog box should now look like the following screen.

6. Click on OK  to use these settings.

You can save these settings for later use. To save them, you choose 
Settings»Save Settings As... from the main window. To retrieve saved 
settings, you choose Settings»Load Settings... from the main window.

7. If the Action window is hidden, bring it to the foreground by choosing 
Windows»Action Window from the main window. A picture of the 
Action window follows.

8. Click on the Capture button in the Action window. The analyzer is 
ready to capture GPIB events.

9. Open the Win32 Interactive Control utility by selecting 
Start»Programs»GPIB Software»Win32 Interactive Control.

10. At the prompt, enter $ "c:\Program Files\National 

Instruments\GPIB\Analyzer\tutorial.txt"  to run the 
tutorial script. (The path to the file may be different if you did not use 
the default installation directory when you installed the GPIB 
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Analyzer software.) Wait until the script has executed. The NI-488.2 
commands in this script file write data on the GPIB, and the analyzer 
portion of the GPIB hardware captures the data.

11. At the :  prompt, type quit  and press <Enter> to exit the Win32 
Interactive Control utility.

12. Switch back to the GPIB analyzer, and click Off  in the Action window 
to stop the capture.

13. In the active Capture Display window, use the scroll bar to go to the 
beginning of the capture file.

The Capture Display window should look like the following screen.

By default, the capture display is in detailed mode, which shows one 
GPIB event per line. This mode shows the greatest amount of detail, 
including the status of each GPIB line and helpful mnemonics. In this 
display, you can see that the tutorial script file issued the following 
commands: clear the GPIB interface, address a device to listen, and 
write data to the device.

14. Change the display mode from detailed to summarized by clicking on 
the arrow beside the Display Mode spin control. Summarized display 
mode is often easier to read if you do not need to see one event per line, 
but it displays less information.
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Part 2: Capture and View New Data with a Trigger 
Condition

1. Choose Settings»Change Settings... to bring up the Settings dialog 
box.

2. In the Capture Stimulus section, choose to capture data transfers and 
command transfers. Unselect the checkboxes for the other types of 
transfers. This will restrict the analyzer to capture only data and 
command transfer events on the bus.

3. Click on “Maximum” in the Handshake rate box to see your choices. 
Then click on the 1 Kbyte/s option. This handshake rate will slow 
down the GPIB transfers.

4. Choose to retain up to 50 capture events.

5. Select the Enable Timestamping box to turn on the timestamping 
feature.

6. In the Trigger Condition  section, enter “1” in the ASCII  edit control 
and notice the corresponding changes in the Hex box and the D8-D1 
toggle switch boxes. 

7. Use the binary switches to set the ATN  line to 0, NRFD to 0, 
NDAC to 1, and DAV to 1. Leave the EOI , SRQ, REN, and IFC  lines 
set as don’t care (x).

8. Make sure Capture around first trigger point shows up as the current 
setting. This option stops the capture when a certain number of events 
have been captured after the trigger point. Use the Thumb denotes 
first trigger point  to specify how many events to capture before and 
after the trigger point. Move the slider below Thumb denotes first 
trigger point  so that the capture file will show 5 events before the 
trigger point and 44 events after the trigger point.

9. Click in the spin control with the words Trigger on first occurrence 
of condition to see your choices. Select Trigger on all occurrences of 
condition. This option captures and displays all occurrences of the 
trigger condition.
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10. Click in the spin control with the words Do not sound a beep on any 
trigger to see your choices, then select Sound a beep on first trigger 
point.

The Settings dialog box should look like the following screen.

11. Click on OK  to use these settings.

12. Bring the Action window to the front by choosing Windows»Action 
Window. Click on the Capture & Trigger  button. The analyzer is 
ready to capture data and look for the trigger condition specified in the 
Settings dialog box.

13. Bring the Capture Display window to the front, and notice that the 
changes you made in the Settings dialog box are shown in the Capture 
Settings section since you clicked on Capture & Trigger .

14. Open the Win32 Interactive Control utility by selecting 
Start»Programs»GPIB Software»Win32 Interactive Control. 

15. At the prompt, enter $ "c:\Program Files\National 

Instruments\GPIB\Analyzer\tutorial.txt"  to run the 
tutorial script again. (The path to the file may be different if you did 
not use the default installation directory when you installed the GPIB 
Analyzer software.)
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16. Switch back to the analyzer program, and click on Off  in the Action 
window to stop the capture. 

17. In the active Capture Display window, click on Switch to Inactive 
Display.

18. If necessary, switch to detailed display mode. Scroll to the top of the 
capture display.

The Capture Display window should look something like the following 
screen.

The trigger points are enclosed in dotted boxes and the display shows 
five events before the first trigger point. 
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19. Choose File»Save As....

20. Enter tutor2.cap  as the capture filename and click on Save. Notice 
that tutor2.cap  appears on the title bar of the Capture Display 
window.

21. From the main File menu, choose Exit  to quit the analyzer application.

Part 3: Search for Data in a Capture Display

1. Open the GPIB analyzer application.

2. Choose File»Open Capture File....

3. In the dialog box, enter tutor2.cap  to retrieve the capture file that 
you saved in part 2 of this tutorial, and click on OK . The capture file 
is automatically opened as an inactive display.

4. Click on the Find... button in the Capture Display window to bring up 
the Find dialog box.

5. Select the Find Trigger  checkbox to search for the captured trigger 
event, ASCII 1, which was the trigger point specified in part 2 of this 
tutorial. The trigger pattern is displayed in the Input Bus State field 
and the Find String  field. 
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6. Click on Find to start the search. The result will be highlighted as 
shown in following screen. ASCII 1 appears in the “A” column of the 
highlighted row.

7. Click on the Find... button to bring up the Find dialog box.

8. Unselect the Find Trigger  checkbox.

9. In the Input Bus State section, enter “5” in the ASCII  edit control.

10. Click on Find to locate the search pattern.

11. Return to the Find dialog box. 

12. To create a string to search for, first choose Insert Below to enter 
another pattern in the Input Bus State.

13. Enter “6” in the ASCII  edit control to indicate the second pattern in the 
search.
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14. Choose Insert Below again, but this time enter “7”. These characters 
form a string (“567”) that the analyzer will search for in the capture 
file. The Find dialog box should look like the following screen.

15. Click Find to search for the string “567”.
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16. The first character of the matched search string, “5”, will be 
highlighted as shown in the following screen.

17. Click on the Find Next button to continue your search. The next 
successful search result will be highlighted. 

Part 4: Show Statistics for Captured Data 
Use the tutor2.cap  capture file that you obtained in part 2 and opened in 
part 3 of this tutorial.

1. In the Capture Display window create a marker at the line containing 
the ASCII character “A” by double-clicking on that line. The marker 
M0 appears in the marker column of that line.

2. Create another marker at the line containing the letter “Z”. M1 appears 
in the marker column of that line.

3. Click on the word Begin in the From spin control in the Markers & 
Statistics group box to see your choices, then select M0, the marker 
for the letter “A”. 

4. Choose M1 for the To list box. 
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The analyzer calculates and displays statistics as shown in the 
following screen.

The capture display statistics show the total number of captured events 
from marker M0 to marker M1. The Time elapsed statistic shows you 
the total time to transfer this block of data. The Capture events per 
second box shows system performance during this period of time.

5. Choose M0 in the Go To list box to highlight the line with the 
letter “A” again. 



Chapter 4 Tutorial

GPIB Analyzer User Manual 4-12 © National Instruments Corporation

Part 5: Print and Export a Capture File
This part of the tutorial is continued from part 4. Use the tutor2.cap  
capture file that you used in part 4.

1. Choose File»Print....

2. In the print dialog box, select M0 for the From Marker  and M1 for 
the To Marker .

3. Click on OK . The portion of the capture display from M0 to M1 will 
be printed. If you want to print the entire capture display, choose Begin 
for the From Marker  and End for the To Marker .

4. Save the capture file as ASCII text by choosing File»Export.... 

5. Enter sample.txt  in the export dialog box, and click on Save. You 
can view the exported file in a text editor, but you cannot import it back 
to the analyzer. 

6. From the File menu in the main window, choose Exit  to quit the 
analyzer application.
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5
Examples

This chapter contains several examples that illustrate how to use the 
analyzer application to solve your IEEE 488 problems.

Example 1: Slow Communication

Description of Problem
A technician is running a GPIB application program in which an 
AT-GPIB/TNT+ board is communicating with a multimeter. In the 
application, the Controller instructs the instrument to reset to its default 
settings, measure Ohms, and return a reading. The application seems to be 
running slowly, and the technician wants to determine the cause of the slow 
performance.

Setting up the GPIB Analyzer 
By using the timestamping feature of the GPIB analyzer, the technician can 
determine what is causing the application to run slowly. In the Settings 
dialog box of the GPIB analyzer, he chooses the following settings:

• Capture data transfers, command transfers, and control line transitions

• Retain 10,000 events

• Timestamping feature enabled

• Do not participate in acceptor handshake
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The Settings dialog box looks like the following screen.

The technician clicks OK  to close the Settings dialog box and clicks on 
Capture in the Action window to start capture, then runs his application. 
After the application executes, he switches back to the analyzer and clicks 
Off  in the Action window to stop capture.
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Reading the Capture Display
The following picture shows the resulting capture display.

The technician has chosen Summarized display mode. In the capture 
display, he sees the string “RST; OHMS; VAL1?”, which instructs the 
multimeter to reset, measure Ohms, and send a reading to the Controller. 
The next string, “+150.38E+0” is the reading from the device. The 
technician switches back to detailed display, and after he places the markers 
in the capture display, he selects various markers in the From and To list 
boxes. For example, he calculates the time the device takes to start sending 
its measurement, which is 1 s, 81 ms, 429 µs, and 450 ns. The statistics that 
the technician sees reveal that the system performance is satisfactory, but 
the instrument is slow in returning a measurement. 
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Example 2: A Service Request Problem

Description of Problem
A test engineer has a GPIB system with two GPIB devices connected. The 
engineer expects that when a device requests service, it asserts the SRQ 
line. He has specified in his application that when SRQ is asserted, the 
Controller serial polls the active devices to determine which device is 
requesting service and then takes the appropriate action. In this particular 
application, the time between the device asserting SRQ and the device 
receiving service is too long, so the engineer wants to check the SRQ and 
serial poll response of his system.

Setting up the GPIB Analyzer 
By using the timestamping feature of the GPIB analyzer, the engineer is 
able to view the service request process and measure response times. He 
configures the analyzer to trigger at the assertion of SRQ and to capture 
GPIB events afterwards. By observing the captured events with 
timestamping information, he learns more about the sequence of events 
during a serial poll of his system.

In the Settings dialog box of the GPIB analyzer, the engineer chooses the 
following settings:

• Capture data transfers, command transfers, and control line transitions

• Capture 500 events after the trigger point

• Trigger condition set to SRQ asserted (SRQ = 1) and all other lines 
equal to “x”

• Timestamping feature enabled

• Capture around the first trigger point
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The Settings window looks like the following screen.

The engineer chooses Capture & Trigger  in the Action window and runs 
his application program.
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Reading the Capture Display
The resulting capture with two added markers (M0 and M1) looks like the 
following screen.

The marker M0 appears on the first line, which shows the assertion of the 
SRQ line. The engineer places a marker M1 where the Controller starts the 
serial poll by sending the Unlisten command (UNL). By choosing M0 in 
the From list box and M1 in the To list box to calculate the Time elapsed 
statistic, he sees that the Controller takes 851 ms, 449 µs, and 200 ns to 
respond to the serial poll. 

The Controller sends its listener address (LA0 in this case) and the serial 
poll enable (SPE) command. The Controller sends TA1 so that the first 
device can talk, then unasserts ATN and reads the status byte (0x00) from 
the device. By reading the timestamp information on the line where the first 
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device sends 0x00, the engineer knows that the device takes 103 ms, 3µs, 
and 40 ns to send its status byte. 

Because the first device is not the one requesting service (because its status 
byte does not have bit 6 set), the Controller addresses the second device to 
talk. The Controller then reads the device’s status byte (0x40), which 
indicates that it is requesting service. By reading the timestamp information 
on the line where the second device sends 0x40, the engineer sees that the 
device takes only 1 µs and 50 ns to send its status byte.

Because the response time of the second device polled is shorter than the 
first device, the engineer changes his application so that the Controller 
always polls the faster device first. If the faster device is the one requesting 
service, the Controller will not need to poll the slower device.

Example 3: Device Not Responding

Description of Problem
A programmer has written a GPIB application program, but her device is 
not responding to the program. 

Setting up the GPIB Analyzer
The programmer configures the analyzer so that she can check for 
communication problems. In the Settings dialog box of the GPIB analyzer, 
she chooses the following settings:

• Capture data transfers, command transfers, and control line transitions

• Retain 60,000 events

• Participate in handshaking and transfer rate set to maximum

• Timestamping disabled
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The Settings dialog box looks like the following screen.

The programmer chooses Capture in the Action window and captures the 
sequence of events on the GPIB. She then clicks on Off  in the Action 
window of the analyzer.
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Reading the Capture Display
The resulting capture display looks like the following screen.

In this example, the Controller does not seem to be sending any data bytes. 
In her application program, the programmer set up the device to have 
primary address 3 and secondary address 96. She notices, however, that at 
the line containing the marker M0, the Controller configures the device to 
be a Listener at primary address 3 with no secondary address. The device 
is not responding because the Controller is not addressing it correctly. The 
programmer corrects her application and runs the capture again. The 
Controller can now write to the device, and the capture display looks like 
the following screen. 
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Example 4: Timeout Error During a Read

Description of Problem
A programmer’s application returns a timeout error while waiting to 
receive data from a device.

Setting up the GPIB Analyzer
The programmer configures the analyzer so that he can examine the GPIB 
activity during a read from the device. In the Settings dialog box of the 
GPIB analyzer, he chooses the following settings:

• Capture data transfers, command transfers, and control line transitions

• Retain 60,000 events

• Participate in handshaking and transfer rate set to maximum

• Timestamping disabled
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The Settings dialog box looks like the following screen.

The programmer chooses Capture in the Action window and captures the 
sequence of events as the device sends data on the bus. He then clicks on 
Off  in the Action window of the analyzer.
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Reading the Capture Display
The resulting capture display looks like the following screen.

This capture display shows that the device asserts EOI with the last byte. 
The programmer remembers that he set up his application to expect an 
End-of-String character to terminate the data transfer from the device. He 
changes the program so that it expects the assertion of EOI to terminate the 
data transfer. The application then runs without an error.
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A
Common Questions

This appendix answers common questions about the GPIB analyzer.

Why can’t I use the analyzer to monitor a GPIB application which uses 
the NI-488.2 ibln  or FindLstn  command?

You can use the analyzer to monitor an application with these commands, 
but you cannot select Participate in Acceptor Handshaking in the 
Settings dialog box of the analyzer. Selecting this feature asserts/unasserts 
the NDAC and NRFD lines in response to the Talker’s assertion/unassertion 
of DAV in the GPIB handshake sequence. Therefore, when you run an 
application that executes a FindLstn  or ibln  command, all possible 
GPIB addresses are returned.

How does selecting “Participate in Acceptor Handshake” in the 
Settings dialog box affect the GPIB? 

When Participate in Acceptor Handshake is selected, the analyzer 
circuitry behaves like a GPIB Listener for the duration of the capture and 
participates in acceptor handshaking on the GPIB. You can use this feature 
to slow down GPIB transfers to a particular rate and to avoid overflow 
errors. 

How do I choose a handshake rate? What does “Maximum” mean?

You can use the handshake rate to slow down the transfer rate on the GPIB 
while debugging timing-related problems. Choosing a particular handshake 
rate guarantees that the transfer rate on the bus will be less than or equal to 
that rate. Choosing the Maximum  rate causes the analyzer to respond as a 
Listener as fast as it can without causing overflow errors.
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How do I define a trigger point to capture a command byte such as 
TA0?

In the Settings dialog box, set the data lines of the trigger condition by 
entering either the ASCII or hex equivalent of TA0 or set each of the data 
lines independently to represent TA0. Set the ATN, DAV, and NDAC lines 
to 1. Set NRFD to 0. The remainder of the control lines should be set to x. 
This state of the handshake lines is necessary to guarantee that valid data is 
present on the data lines.

What do the rows of lights and switches in the Bus Monitor window 
represent?

The LEDs represent the state of the bus lines at all times. The toggle 
switches represent the assertion of lines from within the Bus Monitor 
window of the analyzer. So if the LED for a particular line is on, and the 
switch for that line is off (down position), the line is asserted, but not by the 
Bus Monitor.

What is the difference between active and inactive capture displays?

Active capture displays show GPIB events as they are being captured. In 
other words, active capture displays are windows into the single capture 
buffer used to store new GPIB events. Inactive capture displays show 
previously captured GPIB events statically, so that they are unaffected by 
newly-captured GPIB events. You must make the capture display inactive 
if you want to use the search or print features.

What do the “Capture Settings” in the Capture Display window mean?

The Capture Settings section of the Capture Display window shows the 
capture settings that were used when the data in the window was captured. 
They help you interpret the captured data in the Capture Display window. 
They are not necessarily the same as the current capture settings.
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How do I use the timestamping information in detailed display mode 
and summarized display mode?

In detailed display mode, where each line can correspond to only one 
capture event, the timestamp value represents the time elapsed between the 
event on that line and the previous event. So if you want to determine the 
time elapsed between the capture of the first event and the fifth event, add 
up the timestamp values on the second, third, fourth, and fifth lines.

In summarized display mode, where more than one event can be present on 
a line, the timestamp value represents the time elapsed between the first 
event on that line and the first event on the previous line.

How can I prevent overflow errors?

For detailed information about avoiding overflow errors, refer to the Avoid 
Overflow Errors section in Chapter 3, How To....

What information should I have before I call National Instruments?

Before you call National Instruments, make sure you have filled out the 
configuration form in Appendix C, Customer Communication.
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B
Capture Display Mnemonics

This appendix explains the mnemonics that appear in the capture display of 
the GPIB analyzer application.

DAB GPIB data byte captured using the data transfer or 
handshake line transition.

GPIB command bytes captured using the command transfer or handshake 
line transition:

ACG Addressed command group.
CFE Configuration enable.
DCL Device clear.
GET Group execute trigger.
GTL Go to local.
LA0-LA30 Listen addresses 0-30.
LLO Local lock out.
PPC Parallel poll configure.
PPU Parallel poll unconfigure.
SC0-SC30 Secondary command 0-30*.
SDC Selected device clear.
SPD Serial poll disable.
SPE Serial poll enable.
TCT Take control.
TA0-TA30 Talk addresses 0-30.
UCG Universal command group.
UNL Unlisten.
UNT Untalk.

GPIB parallel poll responses captured using the parallel poll response 
capture stimulus:

PP-B Parallel poll is beginning.
PP-E Parallel poll is ending.
PP-R Parallel poll response (occurs between PP-B and PP-E).

* If SC appears after a talk or listen address, it is a secondary address. If it appears after a parallel poll configure, it is either a 
parallel poll enable (PPE) or a parallel poll disable (PPD) command. If it appears after configuration enable (CFE), it is the 
cable length for HS488.
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C
Customer Communication

For your convenience, this appendix contains forms to help you gather the information necessary 
to help us solve your technical problems and a form you can use to comment on the product 
documentation. When you contact us, we need the information on the Technical Support Form and 
the configuration form, if your manual contains one, about your system configuration to answer your 
questions as quickly as possible.

National Instruments has technical assistance through electronic, fax, and telephone systems to quickly 
provide the information you need. Our electronic services include a bulletin board service, an FTP site, 
a fax-on-demand system, and e-mail support. If you have a hardware or software problem, first try the 
electronic support systems. If the information available on these systems does not answer your 
questions, we offer fax and telephone support through our technical support centers, which are staffed 
by applications engineers. 

Electronic Services

Bulletin Board Support
National Instruments has BBS and FTP sites dedicated for 24-hour support with a collection of files 
and documents to answer most common customer questions. From these sites, you can also download 
the latest instrument drivers, updates, and example programs. For recorded instructions on how to use 
the bulletin board and FTP services and for BBS automated information, call 512 795 6990. You can 
access these services at:

United States: 512 794 5422
Up to 14,400 baud, 8 data bits, 1 stop bit, no parity

United Kingdom:  01635 551422
Up to 9,600 baud, 8 data bits, 1 stop bit, no parity

France:  01 48 65 15 59
Up to 9,600 baud, 8 data bits, 1 stop bit, no parity

FTP Support
To access our FTP site, log on to our Internet host, ftp.natinst.com , as anonymous  and use 
your Internet address, such as joesmith@anywhere.com , as your password. The support files and 
documents are located in the /support  directories.
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Fax-on-Demand Support
Fax-on-Demand is a 24-hour information retrieval system containing a library of documents on a wide 
range of technical information. You can access Fax-on-Demand from a touch-tone telephone at 
512 418 1111.

E-Mail Support (Currently USA Only)
You can submit technical support questions to the applications engineering team through e-mail at the 
Internet address listed below. Remember to include your name, address, and phone number so we can 
contact you with solutions and suggestions. 

support@natinst.com

Telephone and Fax Support
National Instruments has branch offices all over the world. Use the list below to find the technical 
support number for your country. If there is no National Instruments office in your country, contact 
the source from which you purchased your software to obtain support.

Country Telephone Fax
Australia 03 9879 5166 03 9879 6277
Austria 0662 45 79 90 0 0662 45 79 90 19
Belgium 02 757 00 20 02 757 03 11
Brazil 011 288 3336 011 288 8528
Canada (Ontario) 905 785 0085 905 785 0086
Canada (Quebec) 514 694 8521 514 694 4399
Denmark 45 76 26 00 45 76 26 02
Finland 09 725 725 11 09 725 725 55
France 01 48 14 24 24 01 48 14 24 14
Germany 089 741 31 30 089 714 60 35
Hong Kong 2645 3186 2686 8505
Israel 03 6120092 03 6120095
Italy 02 413091 02 41309215
Japan 03 5472 2970 03 5472 2977
Korea 02 596 7456 02 596 7455
Mexico 5 520 2635 5 520 3282
Netherlands 0348 433466 0348 430673
Norway 32 84 84 00 32 84 86 00
Singapore 2265886 2265887
Spain 91 640 0085 91 640 0533
Sweden 08 730 49 70 08 730 43 70
Switzerland 056 200 51 51 056 200 51 55
Taiwan 02 377 1200 02 737 4644
United Kingdom 01635 523545 01635 523154
United States 512 795 8248 512 794 5678



Technical Support Form
Photocopy this form and update it each time you make changes to your software or hardware, and use 
the completed copy of this form as a reference for your current configuration. Completing this form 
accurately before contacting National Instruments for technical support helps our applications 
engineers answer your questions more efficiently.

If you are using any National Instruments hardware or software products related to this problem, 
include the configuration forms from their user manuals. Include additional pages if necessary.

Name __________________________________________________________________________

Company _______________________________________________________________________

Address ________________________________________________________________________

_______________________________________________________________________________

Fax ( ___ ) ________________Phone ( ___ ) __________________________________________

Computer brand____________ Model ___________________Processor _____________________

Operating system (include version number) ____________________________________________

Clock speed ______MHz   RAM _____MB Display adapter __________________________

Mouse ___yes   ___no     Other adapters installed _______________________________________

Hard disk capacity _____MB Brand_________________________________________________

Instruments used _________________________________________________________________

_______________________________________________________________________________

National Instruments hardware product model _____________ Revision  ____________________

Configuration ___________________________________________________________________

National Instruments software product ___________________  Version  _____________________

Configuration ___________________________________________________________________

The problem is: __________________________________________________________________

_______________________________________________________________________________

_______________________________________________________________________________

_______________________________________________________________________________

_______________________________________________________________________________

List any error messages: ___________________________________________________________

_______________________________________________________________________________

_______________________________________________________________________________

The following steps reproduce the problem: ___________________________________________

_______________________________________________________________________________

_______________________________________________________________________________

_______________________________________________________________________________

_______________________________________________________________________________



GPIB Hardware and Software Configuration Form
Record the settings and revisions of your hardware and software on the line to the right of each item. 
Complete a new copy of this form each time you revise your software or hardware configuration, and 
use this form as a reference for your current configuration. Completing this form accurately before 
contacting National Instruments for technical support helps our applications engineers answer your 
questions more efficiently.

National Instruments Products
GPIB Hardware Product and Revision ________________________________________________

GPIB Analyzer Software Version ___________________________________________________

GPIB Software Version Number on Distribution Disk(s) _________________________________

Programming Language Interface Version _____________________________________________

Board Settings

Other Products
Computer Make and Model_________________________________________________________

Microprocessor __________________________________________________________________

Clock Frequency _________________________________________________________________

Type of Monitor Card Installed______________________________________________________

Windows Version ________________________________________________________________

Application Programming Language (BASICA, Microsoft C, and so on) _____________________

_______________________________________________________________________________

Other Boards in System____________________________________________________________

Base I/O Address of Other Boards ___________________________________________________

Interrupt Level of Other Boards _____________________________________________________

DMA Channels of Other Boards_____________________________________________________

Base Address
Interrupt 

Level
DMA 

Channel
Board
Type

gpib0 _________ _________ ________ _________

gpib1 _________ _________ ________ _________

gpib2 _________ _________ ________ _________

gpib3 _________ _________ ________ _________



Documentation Comment Form
National Instruments encourages you to comment on the documentation supplied with our products. 
This information helps us provide quality products to meet your needs.

Title: GPIB Analyzer User Manual

Edition Date: November 1997

Part Number: 320931B-01

Please comment on the completeness, clarity, and organization of the manual.

_______________________________________________________________________________

_______________________________________________________________________________

_______________________________________________________________________________

_______________________________________________________________________________

_______________________________________________________________________________

_______________________________________________________________________________

_______________________________________________________________________________

If you find errors in the manual, please record the page numbers and describe the errors.

_______________________________________________________________________________

_______________________________________________________________________________

_______________________________________________________________________________

_______________________________________________________________________________

_______________________________________________________________________________

_______________________________________________________________________________

_______________________________________________________________________________

Thank you for your help.

Name _________________________________________________________________________

Title __________________________________________________________________________

Company _______________________________________________________________________

Address ________________________________________________________________________

_______________________________________________________________________________

E-Mail Address __________________________________________________________________

Phone ( ___ ) __________________________  Fax ( ___ ) _______________________________

Mail to: Technical Publications Fax to: Technical Publications
National Instruments Corporation National Instruments Corporation
6504 Bridge Point Parkway 512 794 5678
Austin, Texas 78730-5039
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Glossary

Prefix Meanings Value

n- nano- 10–9

µ- micro- 10– 6

m- milli- 10–3

k- kilo- 103

M- mega- 106

ASCII American Standard Code for Information Interchange
DIO digital input/output
EOI end or identify
EOS End-of-String
FIFO first-in-first-out
GPIB General Purpose Interface Bus
hex hexadecimal
HS488 high-speed IEEE 488 transfers
IEEE Institute of Electrical and Electronic Engineers
LED light-emitting diode
m meters
s seconds
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Index

A
Accept Byte button, 2-9, 3-2
acceptor handshake.  See handshake.
Action window, 2-7 to 2-8, 3-1
active Capture Display window, 2-9, 2-12, A-2
analyzing captured GPIB events, 2-11, 3-6 to 3-9
application program, GPIB, 5-1 to 5-10
ASCII edit control, 2-6, 2-8, 2-13, 3-2, 3-8
asserting GPIB lines, 2-8 to 2-9, 3-2

B
beep on trigger, 2-7
buffer overflow.  See overflow errors.
buffer size, 2-4, 2-11, 3-3, 3-4 to 3-5
Bus Monitor window, 2-8 to 2-9, A-2

C
capture buttons, 2-7
Capture Display window, 2-9 to 2-12

active, 2-9, 2-12, A-2
inactive, 2-9, 2-12, 3-8, 3-9, A-2

capture file
exporting 2-10, 3-9
opening, 2-2
printing, 2-10, 3-9
saving, 2-10, 3-9

capture settings, 2-4 to 2-5, 2-11, 3-3 to 3-4
capture size, 2-11
capture stimulus, 2-5, 2-11
capturing GPIB events

how to, 3-1 to 3-4
non-intrusive capture, 3-4
overview, 1-2
tutorial, 4-1 to 4-11

changing the trigger/capture settings, 2-3

colors in the capture display, 3-7
command transfers, 2-5
common questions, A-1 to A-2
control lines, 2-5, 2-8, 3-2
configuration of settings, 2-4 to 2-7, 3-3 to 3-6
customer communication, x, C-1

D
data transfers, 2-5 
dialog boxes in the GPIB analyzer

Find dialog box, 2-13, 3-8
Settings dialog box, 2-4 to 2-7, 3-3 to 3-4

display mode, 2-12, 3-6, 3-7, A-2
documentation

conventions used in manual, x
organization of manual, ix
related documentation, x

E
errors

GPIB timeout errors, 5-8
overflow errors, 2-12, 3-4 to 3-5

examples using analyzer, 5-1 to 5-10
exiting GPIB analyzer program, 1-3, 2-3, 3-1
exporting capture displays, 2-10, 3-9, 4-11

F
Find buttons, 2-11, 2-12 to 2-13, 3-8, 4-7 to 4-9
Find dialog box, 2-13, 3-8
find specifications, 2-13
finding captured GPIB events.  See searching for 

captured GPIB events.
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G
GPIB analyzer

capture rate, 2-5
examples, 5-1 to 5-10
exiting, 1-3, 2-3, 3-1
installation, 1-2
overview, 1-1 to 1-2
starting, 1-2
tutorial, 4-1 to 4-11

GPIB applications, 5-1 to 5-10
GPIB lines, 2-8, 2-9, 3-2
GPIB transfer rate, 2-4, 3-4

H
handshake 

checkboxes, 2-4
lines, 2-5, 3-2, 3-5
participation, 2-4, 2-5, 3-2, 3-4, A-1
rate, 2-4, 2-11, 3-5, A-1

Hex edit control, 2-6, 2-8, 2-13, 3-2, 3-8

I
IEEE 488 problems.  See troubleshooting 

IEEE 488 problems.
importing files, 3-10
inactive capture display window, 2-9, 2-12, 

3-8, 3-9, A-2
installation, GPIB analyzer, 1-2

L
launching the analyzer, 1-2
LEDs, 2-8, A-2
loading a capture file, 2-2
loading a settings file, 2-3, 3-6

M
Main window, 2-2 to 2-3
markers, 2-11, 3-9, 4-10
mnemonics, capture display, 3-8, B-1
monitoring GPIB activity, 2-8, 3-2

N
new capture display, 2-2
non-intrusive capture, 3-4

O
online help, 1-1
overflow errors, 2-12, 3-4 to 3-6
overview, GPIB analyzer, 1-1 to 1-2

P
parallel poll responses, 2-5, C-1
printing captured GPIB events

how to, 2-10, 3-9
tutorial, 4-11

R
rates

GPIB analyzer capture, 2-5
GPIB transfer, 2-4, 3-4
handshake, 2-4, 2-11, 3-5, A-1

S
saving

captured GPIB events, 2-10, 3-9, 4-7
settings file, 2-3, 3-6, 4-2

searching for captured GPIB events
how to, 2-12 to 2-13, 3-8 to 3-9
tutorial, 4-7 to 4-10

serial polls, 5-3 to 5-6, B-1
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service request problems example, 5-3 to 5-6
settings configuration

changing, 2-3, 2-4 to 2-7
loading, 2-3, 3-6
saving, 2-3, 3-6

Settings dialog box, 2-4 to 2-7, 3-3 to 3-4
starting capture process, 3-1
starting GPIB analyzer program, 1-2
statistics, capture display, 2-11, 3-9
stopping capture process, 2-8, 3-1

T
technical support, C-1
time notation, 3-8
timestamp

checkbox, 2-5, 3-4
values, 3-7 to 3-8, A-2

trigger condition
boxes, 2-6 to 2-7
changing, 3-3 to 3-4
searching for, 2-13

trigger point.  See trigger condition.
trigger settings, 2-6 to 2-7
triggering on GPIB event.  See also trigger 

condition.
how to, 3-3 to 3-4, A-1
trigger controls, 2-6 to 2-7
tutorial, 4-4 to 4-7

troubleshooting 
analyzer problems, A-1 to A-3
IEEE 488 problems, 5-1 to 5-10

V
viewing 

capture data, 3-6 to 3-8, 4-1 to 4-7
GPIB line states, 2-8, 3-2

W
windows of the GPIB analyzer

Action window, 2-7 to 2-8, 3-1
Bus Monitor window, 2-8 to 2-9, A-2
Capture Display window, 2-9 to 2-12

active, 2-9, 2-12, A-2
inactive, 2-9, 2-12, 3-8, 3-9, A-2

Main window, 2-2 to 2-3
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